Jump to content

Registered users (members) don’t see this ad!

Sign in to follow this  
tursup

1993 Pickup Idle

Recommended Posts

My daughter has a 1993 Toyota Pickup that recently started having an idle problem. It has 180,000 miles and previously had no issues. When you start it up, the engine idles high (1,200 rpm). Once warm it will pulse from 1,000 to about 400 rpm, is there something to check first? Thanks.

Edited by tursup

Share this post


Link to post
Share on other sites

For this vintage of truck - there are three possible places I'd check first. One is the idle adjustment screw - should be located very close to the throttle cam - they have a tendency to back out over time and mess with the idle. Other is close to the back of the engine - the EGR's plumbing, there is a place where a bunch of vacuum hoses plug into a valve - sometimes one of those vacuum hoses will be damaged, missing, or just got disconnected. Might just need a good throttle body cleaning - even a fairly small amount of varnish and gunk can cause idle issues.

 

Other than that - could be any number of things. Bad tank of gas, fuel line leaks, vacuum leak, exhaust leak, etc. But the above are pretty common the Toyota trucks.

Edited by fishexpo101

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×