Jump to content

Registered users (members) don’t see this ad!

Sign in to follow this  
mjusa

Horn Not Working

Recommended Posts

I solved the problem finally. I checked the fuses and they were fine. I replaced the relay and the relay was not the cause of the problem. Then I realized that then I press the center of the steering wheel to engage the horn there is no click which is the noise which indicates that the relay is engaged. <<If I am incorrect in the technicals of this post please correct me>>. So I decided that I have to remove the center steering cover which houses the airbag. To do this you have to remove the two plugs from left and right sides of the steering wheel if steering is centered. Then unscrew the two screws and slowly remove the center cover. Unplug the airbag wire so that the cover can be removed. Once I did this I realized what the problem was. The horn wire was split and all I had to do was fix that and the problem was solved. I hope this helps others in the future.

Excellent update for the solution. Most of us thought it was a horn, or relay problem.

The horn switch in the steering wheel seldom goes bad, but you found that your wires there were bad.

Good to hear that your horn is working again!

Share this post


Link to post
Share on other sites
trap
Its a Fram Truck Air Horn that comes with a compressor. Its not for a normal pickup truck its for those Semi's.

Hook it up and see how it sounds!

Share this post


Link to post
Share on other sites

If this is something you are going to look at yourself then I would be locating the horn at the front of the car, take the wire off clean it up and put a tester on it, if you don't have a tester then a simple bulb, ask someone to press the horn and see what you get there,

It may be you need a new horn! http://bit.ly/2obFLAv

Edited by Lexy Thompson

Share this post


Link to post
Share on other sites

If this is something you are going to look at yourself then I would be locating the horn at the front of the car, take the wire off clean it up and put a tester on it, if you don't have a tester then a simple bulb, ask someone to press the horn and see what you get there,

It may be you need a new horn! http://bit.ly/2obFLAv

 

https://www.summitracing.com/int/parts/wlo-320-2t/overview/

 

https://www.summitracing.com/int/parts/hla-007424801/overview/

Edited by dom

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

(Only shown to guests, not registered members.)


×