Jump to content

Registered users (members) don’t see this ad!

Sign in to follow this  
Guest gary

Corolla Starting Trouble When Engine Hot

Recommended Posts

Guest gary

Hi,

 

I have a 97 Corolla. No starting problem when engine is cold. However, when I turn the engine off and try to restart within a few minutes, it won't start. The engine turns. After this has happened a few times, I smell gas fumes. After a little while, it starts up. This is especially frustrating when I am at the gas pump.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

So the engine cranks OK when hot - just doesn't fire up? How long has it been since the last tune up on the car? Does the car run OK when cold and it warms up? How does the car run after you get it to finially start, from a hot engine?

 

Fuel smell after the attempts to start is normal - that is just because you were not able to light off the air/fuel mix initially. This sound like there is an issue with the ignition system (cap, rotor, plug wires, sparkplugs, coil) or air being sucked into the fuel line. Might need just a tune up and all is well. I would also check that the fuel log (tube that feed fuel to the injectors) is not leaking fuel when hot, make sure charging system is up to par, might also be a good idea to make sure the injectors work themselves (audible check). Make sure the cooling system it up to par as well. Everything has to work in concert - any breaks in the line will make the other systems more susceptible to damage or failure.

Edited by fishexpo101

Share this post


Link to post
Share on other sites
Guest gary

No idea when the last tune-up was done - I bought this used in Nov. 2005. It is a 1997.

 

As regards how it runs when it finally starts, I have been noticing that it tries to stall when I am stopped at a red light even when the engine is hot. It kind of sputters and then comes back to life.

 

Thanx...

Share this post


Link to post
Share on other sites
No idea when the last tune-up was done - I bought this used in Nov. 2005. It is a 1997.

 

As regards how it runs when it finally starts, I have been noticing that it tries to stall when I am stopped at a red light even when the engine is hot. It kind of sputters and then comes back to life.

 

Thanx...

 

Definitely time for a tune-up.

Share this post


Link to post
Share on other sites

Could also be a problem with the EVAP, EGR, or clogged cat - hard to say - but a quick tune-up would be a very good idea. At the very least, it would eliminate some unknown variables and help you narrow down the field.

Share this post


Link to post
Share on other sites

Parts tend to wear out after normal usage. The rough running could be those parts being worn. Usual tune-up would include spark plugs, wires, distributor cap and rotor. They do a lot for consistent spark and running condition. Change oil and oil filter as well as air and fule filters. Have timing checked and also change drive belts. Clean any sensors and especially fuel injectors. All that will help you have a much smoother running engine that starts and runs well every time.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

(Only shown to guests, not registered members.)


×
×
  • Create New...