Jump to content

Registered users (members) don’t see this ad!

Search Corolland

Showing results for tags 'shifting'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Corolland Forums: about Toyota

  • Corolla Forums
    • Toyota News and Rumors
    • Corollas
    • TNGA platform: 2019 Corolla, RAV4, Camry, Avalon
    • All Other Toyotas
    • Appearance, Audio, Electronics
    • Buy and Sell Cars and Parts
    • Anything but Toyotas

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


From (required)

Found 1 result

  1. Hello everyone! I am resurrecting an old topic, sort-of. I posted about this previously thinking it was a tranaxle problem, but I'm not sure it is anymore... I have a 2010 Corolla S with 153,000 miles on it. If I am traveling down the road in overdrive doing 45+ mph, life is good. On occasion, if I need to accelerate, the kick-down from OD to third or second is occasionally met with a very hard jolt that has a very expensive feel to it. This winter, it became so bad that I took it in to the transmission shop to have it looked at. $100 and a full diagnostic with drive test later they said they couldn't replicate the issue, the fluid looked great, pressure was great, and everything appears to be running just fine. They were confident that there was a lot of life left in the transmission. I wish I could remember, but they also said they cleared a computer or module and wanted me to see if that helped. And, for a little time, it did seem to help a little. But it wasn't long before the problem returned. Just as I was thinking I should take it in again and drive with them, the weather changed from cold to warm and the problem has gone away. But I suspect it will be back in the colder weather. This is a reputable transmission shop that does good work, so I don't doubt them that the diagnostics came back clear. But if that's the case, what else could be the problem? Downshifts, as if I was coming to a stop, are smooth - but when stopped I notice my engine hunting for a smooth idle speed between 750 and 1,000 RPM, which is kind of unusual and rough until it figures things out. It's only during kick-downs and it's hard to predict when it will happen until just before it occurs. While it is unpredictable, I can tell when it's about to happen a couple seconds before it jolts. Usually when I give more throttle, the kick-down feels "normal" and somewhat immediate. When the problem is about to occur, I give more throttle and the car doesn't accelerate or it will try to accelerate while in OD (with little success) for about three or four seconds - then all the sudden, bang, and you're in third or second. However, if I feel the hesitation and I let off the gas a little and then force the kick-down again, it's usually okay. I've had the problem occur when I need hard WOT acceleration right away and I've had it happen with lazy, barely giving gas to pass the car in front, throttle inputs. I'm wondering if there are any ideas or suggestions on what to check or replace. I've cleaned the MAF, which was a long shot, and my throttle body is spotless. I've read it could be a catalytic converter could be plugged, a bad TPS, bad fuel pump, and bad speed sensor. But, all of of those things have costs associated with them and I would rather not guess at a fix and spend money on something unnecessary. Thank you for reading!
×
×
  • Create New...