Jump to content
Corolland: the Toyota Corolla Forums

Recommended Posts

Willow, my mom's Corolla and my avatar here had a dead battery and sat for a while. The car's radio was weak with the headlights before that, so the battery was thought old. When the original battery was hooked up to jumper cables, the car would crank but not start and  (this was true before the weeks of sitting)was no crank without cables. We think the critters we know were around the car may have chewed some wires, perhaps, due to the lights not all lighting. She (named cars get feminine pronouns if they fit with the name in my family) went to a garage my family's used before on a flatbed. They seem backed up as they haven't called us as I type this.

Share this post


Link to post
Share on other sites

That's pretty bad but not unusual. Might still be the battery though. Sometimes with  a cheap set of jumpers and a bad battery you can't get enough current through.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...