Jump to content
Sign in to follow this  
Opium

99 Prizm A/c Fuse Keeps Burn/ Popping

Recommended Posts

I changed the fuse with the exact same 7.5 amps. When I turn on the a/c cold, the a/c button stays lit for a second and it sounds like the compressor comes on but then the a/c light turns off, the compressor off and the air doesnt come out cold, the new fuse blown. What are the possible causes, to this?

Share this post


Link to post
Share on other sites

Something is definitely drawing a lot of current, causing the fuse to blow out. Does it blow when you switch to defrost?

 

Could be a number of things - first thing I'd check is the refrigerant level in the AC system, make sure it is OK. If the level is too high, the compressor has to work a lot harder, causing it to put a lot of load on that clutch. If the clutch burns up - when it engages, it could draw a ton of current. Too low - the compressor shouldn't even come on, as a safety feature. More than likely - it is a faulty magnetic clutch that is causing the heavy current draw when you first power it up. You'll have to take it to a qualified HVAC place to double check it top to bottom - could be something really simple and not a bad clutch.

 

Could also be wiring that got shorted out somewhere - maybe the insulation is worn off at a point close to a chassis ground. Those can be a nightmare to trackdown - as you have to trace back each wire by hand to make sure it is not shorted.

 

Anything else that happened to the car recently? New audio system, any recent electrical work, did it do this before, did it pop fuse for any other reason/different component?

Share this post


Link to post
Share on other sites

The a/c compressor is about a year ago. Its a Delphi one. I'm thinking its the clutch coil. I haven't added any thing new, no new audio system.

Share this post


Link to post
Share on other sites

I found the issue, cable was a tad bit chewed. I'm trying to find out the part number/name of the cable so I can replace it.

 

kCL0RBk.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

trap


×
×
  • Create New...