Jump to content
Sign in to follow this  
Asfand

Vibration At Low Rpm Corolla 1997

Recommended Posts

Just wondering what is causing it. Bought this corolla 1997 model with 167K miles on it. Runs fine but the vibrations at certain low RPM causes displeasure.

 

Is it engine mounts? OR something else?

 

Please provide some help in eliminating this problem.

 

Best Regards

 

:(

Share this post


Link to post
Share on other sites

Vibrations from a roll or at a stop? Do they change in intensity or frequency if you turn left/right/accelerate/slow down/stop? Do you feel the vibrations if they car is stopped in neutral/gear - gets better or worse if you start adding some RPMs? Have you tried rotating the tires and see if the vibration moves with the tires? What is the history of the car - accident, major suspension or brake work, condition of the tires/suspension? Tune up recently? Did you have prior experience with a four cylinder car? (ie. I grew up with only V8s, first time I drove a inline 4 - I thought the engine was on its last legs because of the vibration (turned out to be normal)).

 

Vibrations can come from just about everywhere - have to help narrow down the field with a bit more info - or you will be just be tossing darts, blindfolded, at the problem until you hit it.

Share this post


Link to post
Share on other sites

Vibrations at vehicle stopped and engine running. No vibrations at idle speed. Vibrations increase when RPM in increased slightly but goes back to normal at higher RPM.

 

I hope this answers your question.

 

Any help in pointing towards solving this problem is appreciated.

 

:)

Share this post


Link to post
Share on other sites

From your descriptions sounds like the vibration is limited to the engine (vibrations keyed to specific RPMs) - that shortens the list of possible candidates considerably.

 

Engine mounts are a possibility (right age and mileage to be a potential culprit) - as the vibrations are present at a specific RPM range (resonance issue).

 

No vibrations at idle but present at slightly increased RPMs off idle also point to clogged fuel injectors, excessive carbon build up leading to detonation, clogged fuel filter, or clogged EGR. Health of the ignition system should also be checked (cap/rotor/plugs/plug wires/coil pack).

 

Could try running some fule injector cleaner and one step higher octane to test if the injectors are clogged or there is detonation present. If there is no apprent change - it could be the inginition system giving you some grief. Pull the plugs from a cool engine and read the plugs ends for telltale signs of detonation, mix too lean or rich, plug fouling, or just plain worn. Check the cap and rotor for wear and carbon tracking - pretty common problem area for off idle engine vibration. Plug wires should also be checked for physical damage and or resistance issues.

 

The EGR being more likely if you notice the engine sputtering or a heavy drop in RPMs from a quick stop from high speed (coming to a stop at the end of a highway exit ramp for example).

Share this post


Link to post
Share on other sites

:) :) :) :)

 

Thank you very much. I will investigate all the issues you have pointed out. I will post my findings and possibly some pictures.

 

Best Regards

Share this post


Link to post
Share on other sites

Thanks for the help Fishexpo101.

 

I have done the following.

 

Replaced

1) Spark Plugs

2) Spark Plug Wires

3) Rotor

4) Distributor Cap

5) Fuel Filter

 

Now using premium gas. Also used the fuel injector cleaner once.

 

EFFECTS:

 

Vibrations still there but the vibration band and amplitude is reduced. What do you suggest now?

 

Any help is highly appreciated.

:) :)

Regards

Share this post


Link to post
Share on other sites

Did you happen to double check the timing? If it is off - could indicate a stretched out timing belt or something amiss with one of the sensors. At this age and mileage - other potential candidates would be O2 sensors, clogged catalytic converter, leaky exhaust pipe (makes the O2 sensor read lean - will run more fuel and cause a rougher idle), clogged EGR valve, and the previously mentioned motor mounts.

 

I'd do the simple stuff first - assume that you have already checked off the typical tune up items (your list above is very good - don't forget to check the air filter as well?). Then work outwards. Of those items that are left - EGR and engine/transmission mounts are the most likely items - but since it is rough off idle - doesn't really point to the mounts. A clogged EGR valve will cause a slight hesitation that can manifest as a strong vibration - if you do a search for it on the forum - it is not an uncommon problem area in that generation of Corolla.

 

Good Luck

Share this post


Link to post
Share on other sites

Hello Fishexpo,

 

I have a similar problem. Let me explain, please let me know what you think.

It is a 92 corolla, auto transmission.

 

Originally, the car, after running on highway on around 65-70 miles , when coming to a full stop at a traffic light, will have a very rough idle - stutter/vibrate/hesitate , then it will shake and die down. The engine check will be ON. I will restart the car with gear on park, give full gas a few times and it will run fine.

 

This has happenned a few times in the past 2 years.

 

Recently when it died like this and I did the usual workaround, but it never comes back to normal..anytime I come to a full stop, the car will die. A full accelerator/throttle fails to fix it. All I have to do is to shutdown the engine and start it after many hours. The car will run fine without any problems.

 

This week, the car experienced this problem again, and nothing is working. Now whenever I put the car in drive or reverse gears, the car does very rough idle. I put it in Neutral or park, the idle is close to smooth. So it has become a big challenge driving the car around. I just start the car, it idles close to normal, I put it in drive/reverse gear, it idles extremely rough. Actually It cycles between extremely rough and a lesser rough idle. The whole car shakes. If I switch ON the rear window defrost or the AC or headlights, the car mostly dies and the engine check light comes on.

 

I took it to Toyota yesterday, they did a whole day research and said they need to replace the IAC valve and possibly the entire throttle body. But they said they are not sure if it will fix the problem !!

 

I see that the symptoms are very similar to what is reported in this topic and would like to know your ideas.

 

Is it the EGR or the IAC/throttle body or something else.

 

What is the best way to fix it. Should I go to Toyota or some local mechanic shops.

 

Thank You.

Share this post


Link to post
Share on other sites

Could be a combination of things as your symptoms follow many common problem areas.

 

The run on the highway to an exit ramp only to have the engine die at a full stop sounds like an EGR issue.

 

The rough idle from dropping the car into drive sounds more like an ignition or fuel issue than the others - but could be related to an EGR/IAC problem.

 

The extra load on the engine cause by turning on accessories liek A/C, defrost, headlamps, etc - sounds more like am IAC valve problem (its job is to maintain the idle during periods of higher engine loads at idle). Throttle bodies almost never go bad unless there is some physically damage or neglected maintenace (usually a vacuum leak from one of the various hoses coming off of it, sticking throttle plate, or leak throttle body to intake manifold gasket.)

 

Need a bit more info - how many miles are on the clock and did the problem just start or have been an ongoing problem that just continued to get worse?

 

What is the state of tune-up on the car? Was one doe recently? What was replaced at the time?

 

Worse thing to do is start throwing parts at the problem. First you have to find a place willing to diagnose the problem at hand. That will mean a test drive and a comprehesive inspection.

 

They should look at the normal maintence items first - make sure they are in good shape. Then start looking outward to the potential problems areas. To replace the EGR valve could cost a few hundred dollars, easy - but your symptoms can also come from a cracked or damage ignition coil ($250 just for the igniter) or vacuum leak somewhere (cheap part to fix - expensive labor charges).

 

Dealerships or a good independant garage should be able to get this done for you. Or it would make a good DIY project - if you also had some resources there with you (at the very least a Haynes or Chilton's manual).

 

Good Luck.

Share this post


Link to post
Share on other sites

Fishexpo,

 

I forgot to mention that even with all the problems, Once I start driving the car it runs fine and only when I come to a stop it shivers and idles rough.

 

After Toyota cleaned up the throttle body yesterday, the roughness of idle has come down a lot, but it still is not closer to smooth. And Toyota clearly said they just cleaned up the throttle body and did not fix anything.

 

-*-

 

Your questions -

Q) Need a bit more info - how many miles are on the clock and did the problem just start or have been an ongoing problem that just continued to get worse?

 

The car has put on 145000 miles. This problem started 3 years back with the car only dying intermittently after highway drive >65 mph and coming to a stop. Recently the behaviour has changed/evolved as I described originally.

 

Q) What is the state of tune-up on the car? Was one doe recently? What was replaced at the time?

 

-Coolant flush ( last week )

-New tyres ( last month )

-Both axles cracked and hence replaced ( 2 months back )

-muffler replaced ( year back )

-wheel bearings replaced ( 2 years back )

-Brakes replaced ( 2 years back )

 

>>First you have to find a place willing to diagnose the problem at hand. That will mean a test drive and a comprehesive inspection.

 

Yes this has become the major challenge. I realize that there are big rip-off agencies around. The wheel-bearing & brakes replacement above are rip-offs that I later realized. I do not see a willingness to do a test-drive and a complete inspection of this particular issue. Right now my task is to find out the right person that can really fix the problem.

 

The last group did not even check the error code for the "engine check" problem.

 

Any recommendations for an independent garage - I live in NJ / princeton area.

 

Thank you.

Share this post


Link to post
Share on other sites

Good tip, Bitter, on the plugs - I'll bet that a majority of the shops will not even bother to check the gap when they replace them.

 

hyacinthdrive - I would probably get a good tune up in there, as it sounds like it needs it. Idle improvement when they cleaned up the throttle body (pretty easy thing to do but lots of shops do not due this on a regular basis or charge way to much to do it). Might need new plug, cap, rotor, plug wires - pretty much normal wear and tear at this point, if they have not already been changed. Same goes for most of the vacuum hoses under the hood. Many are for emissions related features and can cause the engien to run very poorly if they are cracked or rotted out.

Share this post


Link to post
Share on other sites

when i get a vibration i know its my plug gap, i pull em, regap em to spec, and it idles like a V8 once again! also when i install plugs i always check the gaps, they're NEVER right! one is larger, one is smaller, ect. always check the gap and regap before you install and then check the gap from time to time. i usually do so at each oil change.

Share this post


Link to post
Share on other sites

ouch, you could have pulled a map sensor from the junkyard for about $30 and installed it yourself in about 5 minutes. theres not even any screws, nuts, or bolts! it just plugs in, slips onto a bracket, and has a vac line that plugs into it.

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...