Won't Shift Into Overdrive

L

longshadow

Guest
Hi all. I have an 89' Toyota Carib which is the right hand drive version of the Toyota All Trac. It's pretty much a Corolla. Anyway, I have been having an issue with my car not going into overdrive. The temperature reads cold when I approach highway speed and it has the tendancy when the temperature drops off to nothing to shift back into 3rd gear. Here is what I know:

- its not a transmission issue rather its a safeguard for emissions that disables the car from going into overdrive when the car is cold. So, in reality my car is not cold, it just thinks it is. So what can I do to troubleshoot the root of this communication failure??

Any information would be helpful

Cheers,

Stephen

View attachment 6

View attachment 7

 
...

fishexpo101

I know Karate, Kung Fu, and 47 other dangerous wor
Definitely sounds like a bad coolant temperature sending unit or damaged wiring from the coolant temperature sensor. If the ECM "thinks" the engine is too cool, it will not shift into O/D until the temperatures comes up.

If this is anything like the AE92 with the 4AFE/4AGE engines - the temperature sensor is right on the thermostat hosing, can't miss it. Not 100% familiar with this variant of Toyota - might have better luck posting this on Toyotanation forums, which tends to have a more international user base.

 
My family's '93 Geo Prizm (Corolla engine) had a stuck open thermostat and didn't properly warm up, but I never heard of a car with a Corolla engine not realizing it wasn't cold. None of our Prizms ever had your car's problem.

 

Welcome to Corolland

Welcome to Corolland where you can ask questions or find answers on anything related to the Toyota Corolla.

Please join our friendly community by clicking the button below - it only takes a few seconds and is totally free. You'll be able to ask questions about your corolla or chat with the community and help others.
Ask a Question

HTML

Top