ForumsCorollas2019-21ToyotasTech

tinto99

Members
  • Content Count

    334
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tinto99

  • Rank
    Well-known member
  1. I'm as shocked as you are, Fish. He is quoting $950 for the engine itself, then a couple hundred for some parts, and fluids, coolant flush (is this needed?), etc. The thing that I find ridiculous is the 16 units (hrs) labour quote, which even at $75/hr, greatly inflates the quote. He hasn't told me what is damaged, I will get that info before driving away. Meantime, I am looking for labour quotes from other mechanics (I only took it to this Crappy Tire outlet because of proximity to where I live, but now I am OK with driving cross-city to save some money).He was pretty clear it wasn't reparable, ie. needed engine replacement. OK, I found a cheaper used engine that I can get for $500, I just have to determine if it can 'legally' be installed on my 97 (if it isn't a 97), as per your emissions comment, thanks for that Fish, it never occurred to me. And installed in fewer hours. I'm not ready to say goodbye to my beloved 'Rolla just yet.
  2. The mechanic is quoting a $900 engine plus tons of other stuff, including 16(!) hours of labour, which I find ridiculous. I'm looking to get a $500 engine shipped to me from Toronto (I'm in Ottawa) and installed by somebody at much more reasonable labour rates.
  3. Thanks Fish, but I took it in, the engine is damaged. I need a new engine, $3k, including labour and tax. Does anybody know if I can get an engine cheaper than this, say less than $1k? Ridiculous to pay so much for such an old car.
  4. Thanks Fish. I think I have bigger problems. Popping the hood, I noticed it's almost certainly engine noise, a constant noise that accelerates in frequency when given gas. This is reminiscent of the noise my Volvo S60 made when its engine died in December. Also, it loses power, almost as if a cylinder is dead. Gonna (slowly) drive it in to the local Crappy Tire (closest mechanic to my house) and hope for the best.
  5. Thanks very much fishexpo101. In answer to your questions, the noise doesn't seem to follow acceleration, or braking for that matter. Seems to happen only on idle and coasting. No specific driving action seems to make the noise worse, otherwise. It started making this noise suddenly, not over time, and not after any repair visit or service. Haven't had service in months, probably due for a tune up. The vehicle has close to 170k miles. Thanks for the tips, I will check all those items and post back. Maybe it is something to do with the vacuum after all. Last question, does anybody have an electronic version of a repair guide for this vehicle? Cheers!
  6. Hi all, my 97 Corolla SD, auto 1.6L, makes a metallic knocking noise during idle but only after warmed up, and again while driving but only coasting, ie. not during acceleration. Any ideas? Thanks in advance.
  7. Thanks Jeremy. I reset the CEL by disconnecting the battery. I turns out it was the blown fan fuse after all. Thanks again.
  8. First came on last week when my girlfriend took it a couple of blocks, noticed the light as well as car almost stalling, before immediately coming back home. Not driven since then. Today, I check under the hood, all vacuum tubes look to be in place (including the after-market cruise control ones that tripped the CEL 6 yrs ago). Also, gas cap tightened properly. One problem I noticed was the blown 30A fan fuse. Replaced it, but CEL still on. Besides O2 and plugs, any other ideas? I don't think 7th gens have MAF sensor, correct? Thanks in advance.
  9. Tdk, you're right, he's tired off spending any more money on this vehicle. I also haggled him down quite a bit, and there was a lot of back and forth on this one, so he's frustrated that he can be so close to a sale, then have me request another report. Anyway, Texasrolla, it is a rental, which I knew up front, but I figure this class rental at an airport outlet can't be beaten up too much. If it had been a Mustang, I'd worry more. Thanks to all!
  10. Jim, you're awesome! I am so grateful, thanks very much! Not sure about the last report dated yesterday 'no recalls, open for repair', but I guess it looks clean. Btw, it was a Hertz rental vehicle. Thanks again!
  11. If you live in Ontario you shouldn't have any worries. Every used vehicle must be sold with a history information package that is mandatory here. As for that carfax site....I typed in my vin number and it came back saying they're are two records on my car. I bought mine brand new and I'm sure that's some type of gimmick to make you buy their information. Thanks Muzak. I'm thinking of having the dealer write no accidents on the bill of sale as well. What worries me is that his UCDA auto-check is dated Dec. 6, and he seems hesitant to run a new one. By the history info package, do you mean the UVIP? Thanks again.
  12. Hi to all. I'm on the verge of buying a used 2006 Volvo S60. The dealer (Volvo dealer) gave me some UCDA (Ontario-based) report done in December. He seems reluctant to do a new one, ie. February. Am I paranoid? Meantime, if somebody here has unlimited CarFax, can you please check my VIN? YV1RS592162533811 I did a preliminary search and it shows 3 reports on this car, so I'm worried. Thanks in advance.
  13. Here is a page from the Autozone repair guide: http://autozone.com/servlet/UiBroker?Forwa...23d80169b3e.jsp I hope to do this job any day now (my belt is visibly damaged, it has a small hole at one point and squeals like crazy). Bought a new belt from Canadian Tire for $19.99. If you do it Gold, please post any tips or lessons learned as I promise to when I eventually get around to it.
  14. Awesome! I'll try it this weekend and post an update. Thanks Tim!
  15. Thanks to all. I'll look into the inline heaters.
×